본문 바로가기

아이폰

check_version_conflict': can't activate json-2.0.2, already activated json-1.8.1 (Gem::LoadError)

fastlane을 설치해서 실행하려고 하면 아래와 같은 에러를 만날수 잇다.

옛날 맥 ruby를 사용하고있다면 만날수 있다.(2.2.*)


check_version_conflict': can't activate json-2.0.2, already activated json-1.8.1 (Gem::LoadError)



원인

json 라이브러리가 옛날 버젼이라서 그렇다. 


해결

루비버젼을 올려주면 된다.

rbenv를 추천하길래(공식사이트에서 추천) rbenv를 설치하고 최신 ruby를 받아서 다시 fastlane를 설치하면 바로 해결된다.